Facebook’da Türkçe Karakter Sorunu (Çözüldü)

Son günlerde Facebook’a eklemiş olduğum site içeriği ve linklerdeki Türkçe karakterlerde sorun olmaya başlamıştı. Sorunla epeyce cebelleştim fakat bir türlü düzeltememiştim. Ta ki düne kadar.  Gözümden kaçan ve şüphelenmediğim bir tek site teması kalmıştı. Çünkü uzun süredir kullanıyordum ve böyle bir sorun yaşamamıştım, dosyalarının içeriğinde bir değişiklik yapmadığım için deşüphelenmemiştim temadan. Dün temanın Header.php sini Notepad++ ile açıp, kodlamasını (UTF-8 without Bom) olarak değiştirince sorun düzeldi. Aynı sorunla karşılaşan arkadaşların dikkatine…

Not: Şayet bir cash eklentisi kullanıyorsanız sorun düzelse dahi bir süre daha popüler olan sayfalarınız sorunlu gibi görünecektir. Bunun dışında Facebook’un cash kısmında sayfanız problemli olarak da tutuluyor olabilir. Kesin olarak değişikliğin çalışıp çalışmadığını öğrenmek için kimsenin o gün uğramadığı bir sayfayı tercih etmeniz gerekiyor.

“Facebook’da Türkçe Karakter Sorunu (Çözüldü)” üzerine 12 düşünce

  1. Merhaba sitemde türkçe karakter sorunum yok hepsi utf8 kodlama yalnız haberi paylaş dediğimde facebook türkçe karakterleri vermiyorum. Mysql UTF8 seçili bu sorunu nasıl çözebilirim.

    1. Bunun dışında bir öneri gelmiyor aklıma malesef. Ben de deneme yanılma metoduyla çözebilmiştim bir süre uğraştıktan sonra. Umarım yakın zamanda sorunun cevabını bulursunuz. Hatta çözebilriseniz şayet buradan da nasıl yaptığınız konusunda bilgilendirirseniz beni konu hakkında çözüm arayan arkadaşlara bir öneri daha getirmiş olursunuz. Şayet ben birşey bulursam sitenizin iletişim kısmından bilgilendiririm sizi. İyi çalışmalar…

  2. hocam dediğin gibi crimson editör de header ı açım w/o bom yaptım.Fakat hemen ardından yeni konu açıp paylaşmayı denedim.Sorun yine aynı ama?

  3. bu arada sitenizi kontrol ettim utf-8 görünüyor kodlama biçiminiz. Burada da sorun yok. Bunun dışında mysql i bi incelemenizi önerebilirim. Mysql de tanımlanmış Mysql Bağlantı Karşılaştırması kısımları utf8_general_ci olması gerekiyor. Böyle olup olmadığına da bir göz atın. Ancak herşeyden önce yapmış olduğunuz ilk işlemi tekrar (without bom) yapmayı deneyerek eskisiyle değiştirin. Mümkünse bunu notepat++ programıyla deneyin.

    Ben sorunumu bu şekilde aştım. Biraz aşağıda yorum yazan Özgür Şahin'in sitesini inceledim az önce. Eski başlıklardan birini alıp Facebook'da denediğim zaman sorun düzelmiş olarak görünüyor. Umarım yardımcı olacaktır bunlardan biri. İyi çalışmalar…

  4. peki kodlamanız utf-8 mi. şayet utf-8 değilse yine yapacaktır. yine header dosyasında kodlama biçimini görebilirsiniz. bir de ona bakmayı deneyin.

    1. Rica ederim. Yanlız her işlemde olduğu gibi bu işlemi de yapmadan önce dosyayı her ihtimale karşı yedeklemeyi unutmayın. Kolay gelsin…

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir